Issue
On May 25, 2023, the Malwarebytes Endpoint Agent displayed the following error message.
"UserAgent.app" is damaged and can't be opened.
The device is still protected. This only impacts the agent user interface menu on the device.
Environments
- Nebula
- OneView
- macOS endpoints
Cause
The root cause is being investigated.
Resolution
Remove the damaged UserAgent.app, then manually check for updates.
- Use Finder to navigate to /Library/Application Support/Malwarebytes/Malwarebytes Endpoint Agent.
- Move the UserAgent.app file to the trash.
- On the left navigation menu in Nebula, go to Manage > Endpoints.
- Select the affected endpoints.
- In the top-right, click Actions > Check for Agent Updates.